우분투 8.10 || virtualbox 설치 시 에러


만일 위와 같은 오류가 발생하였다면 여러가지 해결 방법이 있겠지만

나는 이 문제가 linux-kernel 버전과 linux-headers 버전이 달라서 생긴 문제였다.

$dpkg -l |grep linux-headers-generic

현재 linux-headers 버전을 확인 할 수 있고

$uname -a

현재 linux-kernel 버전을 확인 할 수 있다. 이 두개의 버전이 서로 다르면 위와 같은 문제가 생기는 것이다.

$sudo apt-get –purge remove linux-headers-generic

명령어로 헤더를 지워주고

$sudo apt-get install linux-headers-2.6.27-7-generic

로 올바른 버전을 설치하여 준다. 2.6.27-7 은 내 리눅스에 설치된 버전이므로 똑같이 치면 안된다

Leave a Reply

Your email address will not be published. Required fields are marked *